No start/no power?

NJFZ1

Moderator
...
BTW what causes a rectifier to go out?
Well glad to hear that they finally found the problem. Rectifier probably had a diode fail on it and it was basically sending AC current instead of DC current to your battery. That's what killed your original battery and why you were blowing the main fuse when connection the new battery...all makes sense now :)
 

gtbigup01

New Member
Well glad to hear that they finally found the problem. Rectifier probably had a diode fail on it and it was basically sending AC current instead of DC current to your battery. That's what killed your original battery and why you were blowing the main fuse when connection the new battery...all makes sense now :)
Oh!! Ok thanks
 

FPD1089

Member
Great to have access to this knowledge and experiences from others... My bike was doing almost the same thing and fried a brand new battery... Now when I put the newest battery in and the new 50amp main fuse the wires to the fuse and the fuse start to immediately heat up... Had blown one fuse already and immediately disconnected it all... I'm hopin it will be an easy fix!
Has anyone replaced the "rectifier" themselves?
 

Missyl1713

New Member
Thanks for this thread! I love reading stuff like this, so of I ever have these symptoms I have an idea where I should be looking.
Changing the rectifier really doesn't look like all that bad of a job in the manual...


Sent from my iPhone using Tapatalk
 

FPD1089

Member
It was very easy! Just saved myself a service visit! Was able to borrow another Rectifier (from another 08 FZ1) and checked the charging voltage... Never went above 14.5... Huge relief.

Now ordering a new one!
 
Top